Luminesce instability

Major incident Luminesce
2026-04-24 05:00 BST · 4 hours, 45 minutes

Updates

Resolved

The impact caused by this incident has been fully mitigated. No further failures have been observed since 08:15 BST. Work is ongoing to identify the root cause, which will be share once available.

April 24, 2026 · 08:30 BST
Update

Investigation is still ongoing. We have identified that a Luminesce infrastructure component responsible for message processing is consuming excessive memory and encountering connection timeout exceptions causing cascading failures across dependent components. The team is performing a rolling restart of the affected components to restore full functionality while root cause analysis continues.

April 24, 2026 · 08:00 BST
Investigating

We are currently investigating instability with the Luminesce service, impacting queries to certain providers. The team is actively working to resolve.

April 24, 2026 · 05:00 BST

← Back