Luminesce instability

Major incident Luminesce
2026-03-20 17:04 GMT · 1 hour, 57 minutes

Updates

Resolved

The Luminesce service is now stable and this incident has been marked as resolved.

March 20, 2026 · 18:00 GMT
Monitoring

The Luminesce service is currently stable. We are closely monitoring to confirm the incident has been resolved.

March 20, 2026 · 17:45 GMT
Investigating

There is current disruption in the Luminesce service, which we are actively investigating. We will update this page once we have further information.

March 20, 2026 · 17:04 GMT

← Back